Hi All,

It has been a while since I posted. Lately I have been trying to get a 4G modem working on a Cisco 1941 router, but kept having issues. First I noticed that the SIM-card wasn’t good but after replacing this the entire connection still didn’t work. First I made sure that all the iOS images were up-to-date, and there were no more recent firmware updates available. That to badly also didn’t work.

The debug commands are easy to use for this to filter out any problems:

show controllers cellular 0/0/0
show cellular 0/0/0 radio
show cellular 0/0/0 network
show cellular 0/0/0 connection
show cellular 0/0/0 all (to use if you want all of the information including previous commands)
debug cellular 0/0/0 messages callcontrol
debug chat
debug dialer packets
debug dialer events

The original code was:

chat-script lte "" "AT!CALL1" TIMEOUT 30 "OK"
!
controller Cellular 0/0
!
track 1 ip sla 1 reachability
delay down 18 up 18
interface GigabitEthernet0/0
description WAN
ip address dhcp
ip flow egress
ip nat outside
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
!
interface GigabitEthernet0/1
description LAN-LINK
ip address 192.168.123.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
!
!
interface Cellular0/0/0
ip address negotiated
ip flow egress
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
!
ip nat inside source route-map rm-WAN interface GigabitEthernet0/0 overload
ip nat inside source route-map rm-LTE interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 track 1
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 50
ip route 8.8.4.4 255.255.255.255 GigabitEthernet0/0
!
ip sla 1
icmp-echo 8.8.4.4 source-interface GigabitEthernet0/0
threshold 350
timeout 400
frequency 5
ip sla schedule 1 life forever start-time now
dialer-list 1 protocol ip permit
!
route-map rm-WAN permit 10
match ip address 1
match interface GigabitEthernet0/0
!
route-map rm-LTE permit 10
match ip address 2
match interface Cellular0/0/0
!
!
access-list 1 permit 192.168.123.0 0.0.0.255
access-list 2 permit 192.168.123.0 0.0.0.255
!
line 0/0/0
script dialer lte
modem InOut
no exec
rxspeed 100000000
txspeed 50000000
scheduler allocate 20000 1000
event manager applet NAT-TRACK
event track 1 state any
action 0.0 cli command "enable"
action 1.0 cli command "clear ip nat trans *"
action 3.0 syslog msg "WAN failover, cleared NAT"
!

This above configuration is also how it is supposed to be done for the configuration. For some reason adding the following code made it work again. Simply put: make an dialer:

interface Dialer1
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow egress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 1
no cdp enable

Note that you also need to add the following changes as well:

controller Cellular 0/0
lte sim data-profile 1 attach-profile 1
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 5
lte modem link-recovery debounce-count 6
!
interface Cellular0/0/0
no ip address
dialer pool-member 1
!
ip nat inside source route-map rm-LTE interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1 50
!
route-map rm-LTE permit 10
match ip address 2
match interface Dialer1

And that was it. I hope soon I will be able to post here more soon!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.